Index of /

NameLast ModifiedSizeType
Parent Directory/ -  Directory
Archives/2016-Sep-12 10:25:11-  Directory
CONFIG-1.4.41-NT5-Legacy-2.4.1.log2016-Sep-12 09:30:39188.0Ktext/plain
CONFIG-1.4.41-NT5-Legacy-2.5.2.log2016-Sep-15 12:57:53186.9Ktext/plain
CONFIG-1.4.41-NT6-Normal-2.6.0.log2016-Sep-11 09:57:00186.9Ktext/plain
COPYING-LightTPD.txt2016-Sep-11 16:19:221.5Ktext/plain
COPYING-OpenSSL.txt2016-Sep-11 16:19:226.2Ktext/plain
LightTPD-1.4.41-1-IPv6-NT5-Legacy-2.4.1-x86-SSL.zip2016-Sep-12 10:10:458.3Mapplication/x-zip
LightTPD-1.4.41-1-IPv6-NT5-Legacy-2.5.2-x86-SSL.zip2016-Sep-15 15:30:388.5Mapplication/x-zip
LightTPD-1.4.41-1-IPv6-NT6-Normal-2.6.0-x86-SSL.zip2016-Sep-12 09:20:248.5Mapplication/x-zip
PACKINFO-Cygwin-2.4.1-Legacy-x86.txt2016-Sep-12 10:08:455.3Ktext/plain
PACKINFO-Cygwin-2.5.2-Legacy-x86.txt2016-Sep-15 15:29:305.5Ktext/plain
PACKINFO-Cygwin-2.6.0-Normal-x86.txt2016-Sep-11 16:19:225.3Ktext/plain
[ LightTPD for Windows ]
A fast, secure and flexible web server for Windows based systems.

Cygwin binary compilation project migrated from WLMP Project.
DISCLAIMER: We don't support installation package anymore.

Binary files:
- LightTPD-<Ver>-<Rel>-IPv6-Win32-NT6-Normal-x86-SSL.zip	Standard compressed package for NT6+ (Windows Vista and above),
- LightTPD-<Ver>-<Rel>-IPv6-Win32-NT5-Legacy-x86-SSL.zip	Standard compressed package for NT5 only (Windows 2000 / XP / 2003),
Source files:
- LightTPD-<Ver>-<Rel>-IPv6-Win32-Stage1-base.patch		Stage 1 base patches for compile on 'i686-pc-cygwin'.
- LightTPD-<Ver>-<Rel>-IPv6-Win32-Stage2-<*Fix>.patch		Stage 2 source patches for compile on 'i686-pc-cygwin' (optional).
- LightTPD-<Ver>-<Rel>-IPv6-Win32-Stage3-<*Mod>.patch		Stage 3 extra module patches for compile on 'i686-pc-cygwin' (optional).

-------------------------------------------------------------------------------------
NOTICE:
-------------------------------------------------------------------------------------
From Cygwin version 2.6.0 cannot support NT5-based systems anymore.
If you use Windows 2000, XP or Server 2003 then you must use NT5-Legacy package only.
NT6-Normal package supports NT6+ (Vista and above) operating systems only.
-------------------------------------------------------------------------------------

===================
PACKAGE INFORMATION
===================

Package Name:             LightTPD-IPv6 (Win32) - SSL
Package Type:             NT5 and NT6+ Standard Binary (32-bit)
Package Version:          1.4.41-1
Revision:                 CB24958C
Release Date:             2016-09-11

Status:                   Stable Release
Language:                 English
Compilation Platform:     i686-pc-cygwin
Compilation environment:  [NT5 Legacy] Cygwin 2.4.1, GCC 4.9.3
                          [NT6 Normal] Cygwin 2.6.0, GCC 5.4.0

Author:                   Jan Kneschke, http://www.lighttpd.net/
License:                  Revised BSD License

Operating System:         [NT5 Legacy] Microsoft Windows 2000 / XP / Server 2003
                          [NT6 Normal] Microsoft Windows Vista / Server 2008 / 7 /
                          Server 2008 R2 / 8 / 8.1 / Server 2012 / 10 / Server 2016

Supported features:       IPv6, ZLib, BZip2, Crypt, SSL, PCRE, MySQL, LDAP,
                          MemCache, FAM, LUA, XML, SQLite, GDBM

Additions:                [NT5 Legacy] OpenSSL 1.0.2f
                          [NT6 Normal] OpenSSL 1.0.2h

Online documentation:     http://redmine.lighttpd.net/projects/lighttpd/wiki/

Autoconf options:         configure --with-openssl --with-kerberos5 --with-lua --with-ldap --with-attr --with-valgrind \
                          --with-mysql --with-libev --with-fam --with-webdav-props --with-webdav-locks --with-gdbm \
                          --enable-mmap --enable-ipv6 --enable-lfs

Native package name:      [NT5 Legacy] LightTPD-1.4.41-1-IPv6-Cygwin-2.4.1-Legacy-x86-SSL
                          [NT6 Normal] LightTPD-1.4.41-1-IPv6-Cygwin-2.6.0-x86-SSL

--------------------------------------
Important changes since version 1.4.32
--------------------------------------

2016-09-15 - Release 1 / Tag: 1.4.41-1 (Legacy/Cygwin-2.5.2)

- Legacy (NT5) package rebuilt with updated libraries.

2016-09-12 - Release 1 / Tag: 1.4.41-1

- MemCached support removed.
[NT5 Legacy]
- Obsoleted legacy package built only for NT5 (MS Windows 2000/XP/2003).
[NT6 Normal]
- Some libraries has been updated.

2016-02-10 - Version 1.4.39, Release 1 / Tag: 1.4.39-1

- Some libraries has been updated.
- Target compilation patches published.

2014-05-06 - Release 1.4.35, Release 1 / Tag: 1.4.35-1

- Cygwin binary compilation project migrated from WLMP Project.
- Fix Service-Install Tool issues with Windows firewall under NT 6.0+.
- Fix UAC elevation issues with LightTPD Service Tools.
- Some libraries has been updated.

--

Compile:

$ cd /usr/src/
$ wget http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-1.4.41.tar.gz
$ tar xzvf lighttpd-1.4.41.tar.gz
$ cd lighttpd-1.4.41
$ wget http://lighttpd.dtech.hu/LightTPD-1.4.41-1-IPv6-Win32-Stage1-base.patch
$ patch -p1 < LightTPD-1.4.41-1-IPv6-Win32-Stage1-base.patch
$ ./configure
$ make
$ make install

--

Copyright (C) 2014-2016.
dtech(.hu) Software Solutions
LightTPD/1.4.41-1-IPv6 (Win32) PHP/5.4.45 OpenSSL/1.0.2h [WLMP Advanced Server]